Home  ||  Products | Download | Order  ||  Resources | Reviews | Forum | News | Gallery  ||  About


   

Features

Overview
Description
Screenshots
Examples
Effects
Compatibility


Resources

Reviews
Tutorials

Manual
Discussion Forum
Version History


Try & Buy


Compatibility

 

Plugin Galaxy is a Photoshop-compatible plugin that works under Windows XP, Vista, 7, 8 as well as MacOS X and supports 8bit RGB, 8bit grayscale, 16bit RGB and 16bit grayscale images.


It is required that one of the following applications is installed:


MacOS X:

64-bit:
  • Adobe Photoshop (Version CS5 or higher)
  • Computerinsel Photoline (Version 16.50 or higher)
  • LemkeSoft GraphicConverter (Version 8.2 or higher)
32-bit:
    • Adobe Photoshop (Version 7 or higher)
    • Adobe ImageReady (Version 7 or higher)
    • Adobe Photoshop Elements (Version 2 or higher)
    • Adobe Illustrator (Version 10 or higher)
    • ACDSystems Canvas X
    • Computerinsel Photoline (Version 16.50 or higher)
    • Corel Painter (Version 9 or higher)
    • LemkeSoft GraphicConverter (Version 5.7 or higher)
    • Macromedia Fireworks (Version 7 (MX 2004) or higher)

      Other applications that support Photoshop plugins may also work.

Windows:

64-bit:

  • Adobe Photoshop (Version CS4 or higher)
  • Adobe Illustrator (Version CS6 or higher)
  • Computerinsel Photoline 64 (Version 16 or higher)
  • CorelDRAW (Version X6 or higher)
  • Corel Painter (Version 12.1 or higher)
  • Corel Paint Shop Pro (Version X6 or higher)
  • Corel Photo-Paint (Version X6 or higher)
  • Paint.NET (with the PSFilterPdn plugin) (Freeware: www.getpaint.net)
  • Serif PhotoPlus (Version X6 or higher)


32-bit:

  • Adobe Photoshop (Version 3 or higher, Version CS1 or higher)
  • Adobe Photoshop Elements
  • Adobe PhotoDeluxe
  • Adobe After Effects (Version 4.1, 5.0 and 5.5, but not animatable)
  • Adobe Illustrator (Version 7 or higher)
  • Adobe ImageReady (Version 2 or higher)
  • Adobe PageMaker (Version 6.5 or higher)
  • ACDSystems Photo Canvas (Version 2 or higher)
  • ACDSystems Photo Editor (Version 3 or higher)
  • ACDSystems Canvas (Version X or higher)
  • albelli photo book creator (Freeware: www.albelli.co.uk)
  • Ambient Design ArtRage Studio Pro (Version 3 and higher)
  • Arcadia PhotoPerfect (Version 2.9 or higher)
  • ArcSoft PhotoStudio (Version 5.5 or higher)
  • Artweaver Plus (Version 3 or higher)
  • Aurora Borealis Mandala Painter (Version 3 or higher)
  • CADlink SignLab (Version 5 or higher)
  • CDH Image Explorer Pro (Version 4 or higher)
  • Computerinsel Photoline 32 (Version 5 or higher)
  • CorelDRAW (Version 9 or higher)
  • Corel Paint Shop Pro (Version 10 or higher)
  • Corel Photo-Paint (Version 9 or higher)
  • Corel Bryce (Version 4 or higher)
  • Corel Painter (Version 6 and higher, except Version 10 and 11)
  • Deneba Canvas (Version 6 or higher)
  • DigiFoto (Version 3.5 or higher) (Freeware: www.klausdoege.de)
  • DigiSoft ProMedia (Version 2 or higher)
  • DigiSoft ImagePro 2K1
  • Discreet Combustion (Version 2 or higher, but not animatable and preview is bluish)
  • Equilibrium DeBabelizer Pro (Version 4.5 or higher)
  • GIMP (Version 1.2.4 or higher with the PSPI plugin) (Preview doesn't work correctly and may crash if you scroll it too often)
  • Helicon Filter (Version 4.2 or higher)
  • Image Analyzer (with the 8bf Interface plugin) (Freeware: meesoft.logicnet.dk)
  • imageN (Freeware: www.pixoid.com)
  • IrfanView (Version 3.85 or higher, Freeware: www.irfanview.com)
  • Jasc Paint Shop Pro (Version 4.12 or higher)
  • KnowledgeAdventure HyperStudio (Version 4.2 or higher)
  • Logipole Konverter (Version 4 or higher)
  • Macromedia Freehand (Version 7 or higher)
  • Macromedia Fireworks (Version 2 or higher, but transparency isn't correctly displayed in the preview)
  • Magix Xtreme Photo Designer (Version 6 or higher, but applying the plugin to a selection or object causes problems and sometimes random crashes occur, Freeware: www.magix.com)
  • Mediachance PhotoBrush
  • Megalux Ultimate Paint (Version 2 or higher)
  • Megalux Ultimate FX (Freeware)
  • Metacreations Painter (Version 6 or higher)
  • Microfrontier Digital Darkroom (Version 1.2 or higher)
  • Micrografx Picture Publisher (Version 8 or higher, but the preview zoom won't work)
  • Microsoft Image Composer (Version 1.5 or higher, but dragging the preview isn't possible)
  • Microsoft PhotoDraw 2000
  • Microsoft Picture It! Digital Image Pro (Version 7 or higher, but a 100% zoom may not work correctly and Cancel sometimes produces a crash)
  • Newave Chaos Fx: Twilight'76 (Version 1.2 or higher)
  • New World Focus PhotoEditor (Version 4 or higher)
  • Paint.NET (with the PSFilterPdn plugin) (Freeware: www.getpaint.net)
  • 19th Parallel Sagelight (Version 3 or higher)
  • Photobie Design Studio (Version 1.8 or higher) (Freeware: www.photobie.com)
  • Photo Filter Factory (Version 9 and higher)
  • Picmaster (Version 1.25 or higher)
  • Plugin Commander Pro (Version 1.5 or higher)
  • PluginMaster
  • PhotoFiltre Studio (Version 7 or higher)
  • PhotoFiltre (Version 6.5 or higher) (with the 8bf Filters plugin) (Freeware: photofiltre.free.fr)
  • RealWorld Paint.com (Version 2008.1 or higher) (Freeware: www.rw-designer.com)
  • QFX / QFX LE (Version 7 or higher)
  • Right Hemisphere Deep Paint
  • Satori PhotoXL (Version 2.29 or higher)
  • Serif PhotoPlus (Version 6 or higher)
  • Serif PhotoPlus Starter Edition (Version 2 or higher) (Freeware: www.serif.com)
  • SigmaPi Pixopedia 24 (Version 1.0.5 or higher)
  • SigmaPi NiGulp (Version 1.5 or higher) (Freeware: www.sigmapi-design.com)
  • Stoik PictureMan Pro (Version 5 or higher)
  • ThinkTank Ameri-Imager (Version 2 or higher)
  • Ulead Gif Animator (Version 4 or higher)
  • Ulead PhotoImpact (Version 4 or higher)
  • Ulead PhotoExpress (Version 6 or higher)
  • VCW Vicman's Photo Editor (Version 6.9 or higher, but preview dragging causes crash) (Freeware: www.photo-editor.net)
  • WebSuperGoo Achroma
  • Xara X
  • XnView (Version 1.70 or higher) (Freeware: www.xnview.com)
  • Zoner Photo Studio (Version 9 or higher)


Processing images with 16-bit/channel
is only be possible with one of the following applications:

  • Adobe Photoshop (Version 5 or higher)
  • Adobe Photoshop Elements (Version 3 or higher)
  • Computerinsel Photoline (Version 5 or higher)
  • Corel Paint Shop Pro (Version X3 (Service Pack 3) or higher)
  • 19th Parallel Sagelight (Version 3 or higher)

 



Copyright (c) 2000 - 2013 by Harald Heim